top of page

Art by FelicityStarr Group

Public·67 members
Akim Safonov
Akim Safonov

Mac Usb Unable To Unmount Volume For Repair


Summary: This guide tells you what to do when First Aid says "Unable to unmount volume for repair. : (-69673)." when checking your internal or external drive. It's advisable to recover your data with iBoysoft Data Recovery for Mac beforehand to avoid data loss.




Mac Usb Unable To Unmount Volume For Repair



Disk Utility First Aid is the common go-to if you need to check and repair an internal or external drive on Mac. However, it sometimes fails its job and shows the error that reads "Unable to unmount volume for repair. : (-69673)." As the message implied, the error occurs due to a volume could not be unmounted.


There are several reasons for "Unable to unmount volume for repair. : (-69673)." If your drive is in good condition, it likely is actively used by other programs or processes, which are preventing First Aid to unmount it. Nevertheless, if your drive is exhibiting behaviors, such as:


Once your data is secured, you can work on fixing "Unable to unmount volume for repair. : (-69673)." on external drives like a Time Machine backup disk. Make sure you have closed all the programs running on your Mac, then go through the following solutions.


Note: It's worth mentioning that the order to repair the disk or its volumes may have an impact on the result First Aid presents. You can try repairing the disk first, then move on to the volumes. If First Aid reports no errors, the issue is most likely caused by a bug and you don't need to worry much about the drive.


Disk Utility may fail to unmount your drive because it is currently in use by Finder. So, your first step to resolve the error "Unable to unmount volume for repair. : (-69673)." should be stopping Finder from accessing the drive.


Disk Utility can't perform checks and repairs on a live file system, so it always unmounts a disk before repairing it. When the process of unmounting goes astray, it will pop up "Unable to unmount volume for repair. : (-69673)."


Once it's done, Terminal will report back that the targeted disk or volume is unmounted. Now, the drive will be grayed out in Disk Utility and you can re-run First Aid to check whether the issue is gone. If, instead, the command returns the error, "Error: -69673: unable to unmount volume for repair," you need to force unmount the disk.


Do you have any of the drive manufacturer's software installed on your Mac that allows you to unlock, maintain, or back up to or from the drive? When such software exists, there's often a related firmware on the drive. You may encounter "Unable to unmount volume for repair. : (-69673)." if either the software or the firmware isn't working properly, especially after a macOS update.


Since OS X 10.7 Lion, every Mac has a recovery partition that users can turn to when they are having issues with the regular macOS. If First Aid keeps reporting "Unable to unmount volume for repair" when scanning your external drive, you can do it in macOS Recovery.


The last resort to solve "Unable to unmount volume for repair. : (-69673)." on Mac is to reformat the drive. This way, you can fix all the disk errors regarding the file system. However, formatting the drive in Disk Utility will likely fail with the error "Couldn't unmount disk.: (-69888)."


If you still see "First Aid could not unmount the volume for repair," you can select the drive or each volume under the drive, click Unmount in Disk Utility, and then retry First Aid. Suppose manually unmounting the disk doesn't make any difference; then you should try repeating the process in Internet Recovery. If the repair succeeds, you can continue with what you planned to do with your Mac.


Disk Quotas may be the one to blame if you are trying to update or install macOS but receive "Unable to unmount volume for repair." In this case, you need to rename and remove two files using Terminal commands in Recovery Mode.


Fsck is a command-line tool for checking and repairing file system errors on Mac. And there are several cases where it can repair a disk problem that Disk Utility was unable to. So, it's advisable to try repairing the drive with fsck, as we will describe next.


If "Unable to unmount volume for repair" keeps recurring despite all your effort to eliminate it, the last hope is to reinstall macOS after erasing the whole drive. You can first try reinstalling macOS in Internet Recovery.


Mac and its features are excellent unless a data lost and deleted files mess up. This error can occur due to various reasons like disk crashing, unmounting error, partitioning, and others. This article will guide you step by step through various causes and specific ways by which the disk issue can be resolved which will help you to repair the issue of unmounting disk/volume on Mac.


You can start performing the tasks which were halted due to the error. When the first aid could not unmount the volume for repair, try using the "Use the terminal application" method to unmount the disk volume.


Step 3: From the Boot Menu, select 'Disk Utility' and go to 'First Aid' to verify and repair the disk or go to 'Erase' if you wish to format the disk. With repair partitioning, you can unmount the disk for repair.


Like most blue screen messages, the unmountable boot volume error isn't always something to worry about if you only see it once. Sometimes Windows runs into a temporary hiccup that you never have an issue with again.


Usually, though, you'll see the unmountable boot volume error each time you try to boot into your PC, and it won't let you load Windows at all. In that case, proceed with more in-depth troubleshooting.


From here, Windows will run an automatic repair that will hopefully take care of your issue. Once it's done, exit the installer and try to boot your computer normally. If Windows still shows an unmountable boot volume error after this, continue onto the next step.


The Master Boot Record (MBR) or GUID Partition Table (GPT) contains information about where Windows is located on your hard drive and helps the OS load properly when you turn your computer on. If this becomes corrupted, it can lead to an unmountable boot volume message.


If the automatic repair and MBR/GPT repair don't solve your problem, you should next try Chkdsk. This important Command Prompt tool lets you check the storage drive for errors, which may be the cause of the unmountable boot volume message.


We've looked at several steps for fixing an unmountable boot volume stop code error in Windows 10 or Windows 11. Since this is usually caused by file corruption, running the above scans from a Windows recovery disk should fix it most of the time. But in the worst cases, you'll need to diagnose your hardware or even reinstall Windows.


Just had the same problem replacing the Hitachi HDD with a Samsung 850 EVO 250 GB SSD in a mid 2010 13" MacBook Pro. Tried everything to initialise/format the SSD (spent hours researching solutions and creating bootable USB drives etc.) but the Partition option was greyed out on Disk Utility and the Erase option kept failing with the message 'partition failed wiping volume data to prevent future accidental probing'. Was just about to order a USB-SATA adapter to try the SDD externally before ordering a new SATA cable but decided to try something I'd read for another problem 'unable to unmount volume for repair' (see below). I simply taped 2 metal edged areas and it worked like a dream - didn't need to use the alcohol wipe (many thanks to Tech Harmony for this).....


One of the more common problems that can keep First Aid from completing is a failure to unmount the selected device. Historically, this error most often occurred when trying to verify and repair the startup drive. The use of Live Verification, which freezes the file system while verification takes place, should prevent this common error, at least when there are no issues with the startup drive that need to be repaired. But you may see the problem with other drives. This can happen because a process on your Mac is accessing, making changes to, or has locked open files, preventing them from being closed and allowing the unmount process to occur.


Based on the output you posted, your disk might have unmounted just fine. It looks as if the failure came from the wiping part. You may find these links helpful: +failed+wiping+volume+data+to+prevent+future+accidental+probi _data_to_prevent_future_accidental_probing/


Big-Mac: admin$ diskutil list/dev/disk0 #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *500.1 GB disk0 1: EFI EFI 209.7 MB disk0s1 2: Apple_HFS iMac 499.2 GB disk0s2 3: Apple_Boot Recovery HD 650.0 MB disk0s3/dev/disk2 #: TYPE NAME SIZE IDENTIFIER 0: FDisk_partition_scheme *1.0 TB disk2 1: Apple_HFS Beatrice 910.3 GB disk2s1 2: Windows_NTFS For Windows 89.9 GB disk2s2Big-Mac: admin$ sudo diskutil unmountDisk force /dev/disk2Password:Forced unmount of disk2 failed: at least one volume could not be unmountedBig-Mac: admin$ hdiutil detach /dev/disk2hdiutil: detach: timeout for DiskArbitration expiredBig-Mac: admin$


If Disk Utility found errors that it was unable to repair, you may need to erase the disk and reinstall macOS. If you don't have a separate backup of your data, contact Apple's support services for next steps.


If you have checked the connection to be fine and also have rebooted your Mac, but your Mac still fails to mount the external hard drive, it indicates that the unmounting issue is caused by other potential reasons. Before digging out the reason to repair the unmounted drive, you are suggested to try to force mount it on your Mac for sake of efficiency. 2 tips on how to force mount external hard drive on Mac will be laid as follows.


An external hard drive with internal errors can also make it inaccessible to your Mac. One handy storage device repair feature called First Aid can be used to fix an unmounted hard drive on Mac machine. This feature can check the drive for errors and then repair it if necessary. The following is how to access First Aid.


About

Welcome to the group! You can connect with other members, ge...

Members

Group Page: Groups_SingleGroup
bottom of page